Actualización menor de las versiones de Scientific Linux 5.x y 6.x

Introducción

Los procedimientos descritos a continuación permiten realizar la actualización de versiones menores en los sistemas operativos basados en Scientific Linux en sus versiones 5.x y 6.x, es decir, pasar de la 5.1 a la 5.3 por ejemplo mas no para pasar de la versión 5 a la 6.

Recuerde tener suficiente espacio en /var/cache para realizar este procedimiento así como contar con copias de seguridad en caso de que algo salga mal.  Realice los siguientes pasos bajo su propia responsabilidad.

Serie 5.x

# yum remove perl.i386 gaim.i386 gaim-devel.i386
# yum clean all
# rpm -Uvh ftp://ftp.scientificlinux.org/linux/scientific/5x/i386/misc/RPMS/yum-conf-latest.SL.noarch.rpm
# yum update yum
# yum update
# yum clean all
# /sbin/reboot
  • El paso #1 solamente se debe realizar bajo la arquitectura de 64 bits para remover versiones instaladas de 32 bits de estos paquetes.

Serie 6.x

# yum clean all
# yum update
# yum --releasever=6x update
# yum-conf-sl-other
# yum update
# yum clean all
# /sbin/reboot
  • En el paso #3 reemplazar el valor 6x por la versión a la cual desea realizarse la instalación (6.2 por ejemplo).
  • El paso #4 sólo es estrictamente necesario cuando la versión original del sistema operativo que se está actualizando es la 6.0.

Enlaces

Instalar Acrobat Reader en GNU/Linux CentOS 6

Introducción.

En el presente artículo se describe el procedimiento necesario para instalar Acrobat Reader en GNU/Linux CentOS 6 desde repositorios Yum.  Este procedimiento probablemente también es compatible con la distribución Fedora.

Instalación.

Agregar el repositorio al sistema operativo.

# rpm -ivh http://linuxdownload.adobe.com/adobe-release/adobe-release-i386-1.0-1.noarch.rpm

# rpm –import /etc/pki/rpm-gpg/RPM-GPG-KEY-adobe-linux asdf

Listar los idiomas disponibles.

# yum list AdobeReader*

AdobeReader_enu.i486                  9.4.2-1                  adobe-linux-i386
AdobeReader_chs.i486                  8.1.7-1                  adobe-linux-i386 
AdobeReader_cht.i486                  8.1.7-1                  adobe-linux-i386 
AdobeReader_dan.i486                  8.1.7-1                  adobe-linux-i386 
AdobeReader_deu.i486                  9.4.2-1                  adobe-linux-i386 
AdobeReader_esp.i486                  8.1.7-1                  adobe-linux-i386 
AdobeReader_fra.i486                  9.4.2-1                  adobe-linux-i386 
AdobeReader_ita.i486                  8.1.7-1                  adobe-linux-i386 
AdobeReader_jpn.i486                  9.4.2-1                  adobe-linux-i386 
AdobeReader_kor.i486                  8.1.7-1                  adobe-linux-i386 
AdobeReader_nld.i486                  8.1.7-1                  adobe-linux-i386 
AdobeReader_nor.i486                  8.1.7-1                  adobe-linux-i386 
AdobeReader_ptb.i486                  8.1.7-1                  adobe-linux-i386 
AdobeReader_suo.i486                  8.1.7-1                  adobe-linux-i386 
AdobeReader_sve.i486                  8.1.7-1                  adobe-linux-i386 

 Identificar el archivo correspondiente al idioma que se desea instalar e instalarlo junto con el plugin para Mozilla.  En este caso se instalará la versión en inglés (enu), si se desea instalar la versión en español elija AdobeReader_esp.

# yum install nspluginwrapper.i686 AdobeReader_enu

Ejecución.

Para ejecutar la aplicación recién instalada simplemente invóquela en la línea de comandos o al seleccionar un ícono de archivo PDF.

# acroread

Instalar Google Chrome en GNU/Linux CentOS 6

Introducción.

El artículo presentado a continuación describe el procedimiento necesario para instalar el navegador web Google Chrome en GNU/Linux CentOS 6 utilizando repositorios Yum.  Este procedimiento probablemente aplique también para otras versiones de CentOS y Fedora.

Instalación.

Crear el nuevo repositorio de Yum.

# vi /etc/yum.repos.d/google-chrome.repo

[google-chrome]
name=google-chrome
baseurl=http://dl.google.com/linux/chrome/rpm/stable/i386
enabled=1
gpgcheck=1

Si se desea la versión de 64 bits utilizar la siguiente descripción del repositorio.

[google-chrome]
name=google-chrome
baseurl=http://dl.google.com/linux/chrome/rpm/stable/x86_64
enabled=1
gpgcheck=1

Instalar los paquetes deseados.

# yum –nogpgcheck install google-chrome-stable

Además de la versión estable también es posible instalar la versión en desarrollo (google-chrome-beta) y la inestable (google-chrome-unstable).

Instalar VirtualBox en Scientific Linux 5.5

Introducción.

El procedimiento se basa en el estándar para instalarlo en Red Hat Enterprise Linux o en sus derivados (como CentOS), sin embargo fue necesario realizar una pequeña modificación al archivo de configuración del repositorio ya que la versión que reporta SL ($releasever) es la 5.5 mientras que el repositorio está esperando un 5 (sin decimales) para que coincida con un directorio donde se encuentran los paquetes.

Instalación.

Descargar la especificación del repositorio.

# wget http://download.virtualbox.org/virtualbox/rpm/rhel/virtualbox.repo

Actualizar la especificación del repositorio para que la versión reportada del sistema operativo coincida con el directorio de los paquetes.

# vi virtualbox.repo

(modificar la línea del baseurl como se muestra a continuación)

[virtualbox]
name=RHEL/CentOS-$releasever / $basearch – VirtualBox
## baseurl=http://download.virtualbox.org/virtualbox/rpm/rhel/$releasever/$basearch
baseurl=http://download.virtualbox.org/virtualbox/rpm/rhel/5/$basearch
enabled=1
gpgcheck=1
gpgkey=http://download.virtualbox.org/virtualbox/debian/oracle_vbox.asc

Mover la especificación del repositorio en su ubicación real.

# mv virtualbox.repo /etc/yum.repos.d/

Instalar VirtualBox.

# yum install VirtualBox

Reconfigurar el módulo del kernel.

# /etc/init.d/vboxdrv setup

Solución de problemas.

NMI watchdog activo.

Si durante la reconfiguración del módulo del kernel surgen problemas que sugieren revisar los mensajes del sistema de la siguiente manera.

# dmesg

Y en ellos aparecen mensajes como el siguiente, es necesario desactivar la función de NMI watchdog del kernel.

vboxdrv: NMI watchdog either active or at least initialized.  Please disable the NMI

Esto se realiza de la siguiente manera.

# vi /boot/grub/menu.lst

(agregar al final de la línea que empieza por kernel)

kernel … nmi_watchdog=0

Reiniciar el sistema operativo para que el cambio realizados surtan efecto.

# reboot

Enlaces.

Actualizar Linux CentOS 5.4 desde línea de comando utilizando Yum

Introducción.

Linux CentOS utiliza Yum como herramienta para administrar sus paquetes, de manera análoga a como Debian utiliza al Aptitude.

A continuación se describe el breve proceso que se debe realizar para actualizar para actualizar los paquetes y el sistema operativo desde la línea de comando utilizando esta herramienta.

Procedimiento.

Verificar si hay actualizaciones disponibles.

$ yum check-update

Descargar e instalar las actualizaciones disponibles.

$ sudo yum update

Enlaces.