Solucionando mis problemas con el modem Huawei HG530

Introducción

En el apartamento UNE me instaló un gateway Huawei HG530 ADSL.  Como es habitual en estos aparatos incluye cuatro puertos LAN para conectar mediante cable a un igual número de equipos, sin embargo los equipos que yo conectaba sólo funcionaban en el puerto #1, los demás obtenían una dirección IP del servicio DHCP pero no conseguían acceder a Internet.

El problema y la solución

Anoche le dí otra oportunidad al problema y estuve revisando las opciones de configuración web del dispositivo y encontré que bajo la opción Advanced > Port Mapping es posible crear una especie de VLANs entre los puertos.  Tal y como me lo entregaron los técnicos de UNE parecía contener la definición de dos VLANs, la primera incluía al puerto LAN #1 y la segunda a los demás siendo esto coherente con los síntomas analizados.

Para solucionar esta situación removí la segunda VLAN y agregué los puertos LAN faltantes a la primera para permitir la comunicación entre ellos, el puerto WAN y el puerto WLAN.  La configuración resultante se muestra a continuación.

También es conveniente verificar bajo la opción Basic > DHCP que este servicio se encuentre activo a través de todos los puertos LAN, de lo contrario los equipos conectados en ellos no obtendrán una dirección IP de manera automática.

Mejorando la seguridad

Con sorpresa encontré que el firewall también venía desactivado, permitiendo establecer conexiones web y telnet para la administración del router desde Internet.  Para impedir esto se activaron las opciones bajo Advanced > Security.


Así como las ubicadas bajo Advanced > Firewall.

Utilizar un módem HSDPA USB Huawei E1556 en GNU/Linux Ubuntu 10.04

La situación.

El módem venía funcionando correctamente con la versión 9.10 de Ubuntu, sin embargo después de la instalación de la nueva versión (10.04) algo parece haber cambiado y el dispositivo sólo es identificado como un medio de almacenamiento (el controlador para Windows).

El problema.

Según el bug #521578 registrado en el LaunchPad de Ubuntu, el problema parece haber surgido debido a un movimiento de funcionalidades entre los paquetes udev (modem-modeswitch) y usb-modeswitch los cuales son responsables de garantizar que estos dispositivos USB no sean descubiertos únicamente como medios de almacenamiento con los drivers de Windows sino que sean identificados también como módems de banda ancha.  El paquete usb-modeswitch ahora con esta funcionalidad, no se instala por defecto en Ubuntu Lucid Lynx (10.04).

Este problema afecta a varios tipos de módems de la marca Huawei.

La solución.

La solución radica en instalar los paquetes requeridos.

$ sudo aptitude update && sudo aptitude install usb-modeswitch usb-modeswitch-data

Desconectar el módem USB y volver a conectarlo.  Este deberá ser reconocido normalmente a partir de ese momento.

Enlaces.